summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-26 21:15:47 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-26 21:19:43 -0400
commit83c14064ece6362753696162d36caa0ed661d3d1 (patch)
treebc0354c527411235246cc0d0fdf82efe85f0f9cd /gnu/packages/python-xyz.scm
parent8153a402ae3958b4207451d709fd92191c0cab66 (diff)
gnu: Add python-tftpy.
* gnu/packages/python-xyz.scm (python-tftpy): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 15a35cda17..ee7625325c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14643,6 +14643,37 @@ multiple processes (imagine multiprocessing, billiard, futures, celery etc).
(define-public python2-tblib
(package-with-python2 python-tblib))
+(define-public python-tftpy
+ (package
+ (name "python-tftpy")
+ (version "0.8.2")
+ (source
+ (origin
+ (method git-fetch) ;no tests in PyPI archive
+ (uri (git-reference
+ (url "https://github.com/msoulier/tftpy")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gl04ps8h8r7av3h0zbm8gwmkqs9rkk5vf7n8mv2bzrkwvy9hacc"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ ;; The default DEBUG logging level is way too verbose.
+ (substitute* "t/test.py"
+ (("logging\\.DEBUG")
+ "logging.INFO"))
+ (invoke "python" "-m" "unittest" "t/test.py")))))))
+ (home-page "http://tftpy.sourceforge.net/")
+ (synopsis "Python trivial file transfer protocol (TFTP) library")
+ (description "TFTPy is a trivial file transfer protocol (TFTP) Python
+library. It can be used to act both as a TFTP client or TFTP server.")
+ (license license:expat)))
+
(define-public python-greenlet
(package
(name "python-greenlet")