summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-16 17:19:09 +0200
committerMarius Bakke <marius@gnu.org>2022-07-16 18:32:13 +0200
commit8d241c685a35227cd6b733dc16a5ca9a60480722 (patch)
tree0bc4d5526e953a2222f46036e2bc0f12fff00ac0 /gnu/packages/python-xyz.scm
parent572ed223abe57b36e9b5de3f456a925a09bd72af (diff)
gnu: python-chardet: Update to 5.0.0.
* gnu/packages/python-xyz.scm (python-chardet): Update to 5.0.0.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 62ca287449..a9371dccd2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13495,14 +13495,14 @@ simulation, statistical modeling, machine learning and much more.")
(define-public python-chardet
(package
(name "python-chardet")
- (version "4.0.0")
+ (version "5.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "chardet" version))
(sha256
(base32
- "1ykr04qyhgpc0h5b7dhqw4g92b1xv7ki2ky910mhy4mlbnhm6vqd"))))
+ "1amqmz8731ly6f9rkbk09w4jqgmmgyxykd1bawhgrdbqzlmxys03"))))
(native-inputs
(list python-pytest))
(build-system python-build-system)
@@ -13511,7 +13511,10 @@ simulation, statistical modeling, machine learning and much more.")
#~(modify-phases %standard-phases
(replace 'check
(lambda _
- (invoke "pytest" "-vv")))
+ (invoke "pytest" "-vv" "-k"
+ ;; Disable test that fails sporadically:
+ ;; https://github.com/chardet/chardet/issues/256
+ "not test_detect_all_and_detect_one_should_agree")))
;; This package provides a 'chardetect' executable that only
;; depends on Python, so customize the wrap phase to avoid
;; adding pytest and friends in order to save size.