summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-25 00:15:21 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-25 01:57:27 -0400
commit8d8e65998bbd067325c83103cf5c8715017bc024 (patch)
tree91d9557f9a3be0f726a45a79ec2d414919992b4a /gnu/packages/python-xyz.scm
parentd08f90be6f6b66c9fec8fd18693d02ba5058424e (diff)
gnu: Add python-pluginbase.
* gnu/packages/python-xyz.scm (python-pluginbase): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bfe7031eba..413aa7bc81 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5650,6 +5650,31 @@ includes the following improvements compared to @code{pdb}:
(description "Pdftotext is a Python library of PDF text extraction.")
(license license:expat)))
+(define-public python-pluginbase
+ (package
+ (name "python-pluginbase")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pluginbase" version))
+ (sha256
+ (base32
+ "11z2vvbp13828y0x3w39f29p9r9xcix7h7c4fff2w8yfiylk6v7z"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "make" "test")))))))
+ (native-inputs `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/mitsuhiko/pluginbase")
+ (synopsis "Simple but flexible plugin system for Python")
+ (description "PluginBase is a library useful in the development of
+flexible plugin systems in Python.")
+ (license license:bsd-3)))
+
(define-public python-pyparsing
(package
(name "python-pyparsing")