summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-26 00:09:52 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:24 +0200
commit90a1cfe012e9f986a80f5ff9a23cc80ba05ac8aa (patch)
tree08ee0cf690b80aa5fde9d8a87a54a01d2ae142bf /gnu/packages/python-xyz.scm
parent505057f223c8f3d19b886e2cd5aff457845ec52c (diff)
gnu: Add python-csb43.
* gnu/packages/python-xyz.scm (python-csb43): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a9e17ad444..60db55a867 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26676,3 +26676,31 @@ TSV (Sets), ODS (Sets), CSV (Sets), and DBF (Sets).
quite huge, this Guix package doesn't depend on pandas. In case, just also
install @code{python-pandas}.")
(license license:expat)))
+
+(define-public python-csb43
+ (package
+ (name "python-csb43")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "csb43" version))
+ (sha256
+ (base32 "0r0csl9npncnkfafg3rg6xr38d1qr0sxvq7wn7mg9bq41hvvh1si"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-lxml" ,python-lxml)))
+ (propagated-inputs
+ `(("python-pycountry" ,python-pycountry)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-tablib" ,python-tablib)))
+ (home-page "https://bitbucket.org/wmj/csb43")
+ (synopsis "Tools for converting from the Spanish banks' format CSB norm
+43 (CSB43)")
+ (description "This package provides tools to convert files in the format
+used by multiple Spanish banks (standard 43 of the Spanish Banking Council
+[CSB43] / Spanish Banking Association [AEB43]) to other formats.
+
+Supported output formats are: OFX, HomeBank CSV, HTML, JSON, ODS (OpenDocument
+spreadsheet), CSV, TSV, XLS, XLSX (Microsoft Excel spreadsheet), and YAML.")
+ (license license:lgpl3)))