summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-12-28 22:32:39 +0100
committerEfraim Flashner <efraim@flashner.co.il>2021-04-01 15:14:28 +0300
commita45c110c9d77fe7969b992c3090f8b09aa461205 (patch)
treeb03e6d7d6594d6b8892e21d5d656a2b7303b7624 /gnu/packages/python-xyz.scm
parent6def029ab90b7e31d2ab02a97a15c3ca51b11be3 (diff)
gnu: Add python-urwid-readline.
* gnu/packages/python-xyz.scm (python-urwid-readline): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 38b35ee9bf..bcf5d05b20 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7661,6 +7661,40 @@ features useful for text console applications.")
(base32
"11ndnhxd41m13darf5s0c6bafdpkzq1l6mfb04wbzdmyc1hg75h8")))))))
+(define-public python-urwid-readline
+ (package
+ (name "python-urwid-readline")
+ (version "0.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rr-/urwid_readline")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0sq5qgxj7gcfww3ww7idr87isnmp0hi36n241b3q395x1zafdv22"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest"))
+ #t)))))
+ (propagated-inputs
+ `(("python-urwid" ,python-urwid)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/rr-/urwid_readline")
+ (synopsis "Text input widget for urwid that supports readline shortcuts")
+ (description
+ "This package provides a textbox edit widget for @code{python-urwid} that
+supports @code{readline} shortcuts.")
+ (license license:expat)))
+
(define-public python-urwidtrees
(package
(name "python-urwidtrees")