summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-10-08 14:10:49 +0200
committerLudovic Courtès <ludo@gnu.org>2020-10-10 22:40:30 +0200
commitc9a99803dd392969b8dc7f0386c0b99ca40073c9 (patch)
treeef7bc626c6858a555851b636a93c2f3b279d27e9 /gnu/packages/python-xyz.scm
parent1f1996e6a5cc5203e0534dc26fe51b87832082aa (diff)
gnu: Add python-inform.
* gnu/packages/python-xyz.scm (python-inform): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0670eb7e08..37f911b512 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22161,3 +22161,32 @@ CSL 1.0.1 specification. citeproc-py can output styled citations and
bibliographies in a number of different output formats. Currently supported
are plain text, reStructuredText and HTML.")
(license license:bsd-2)))
+
+(define-public python-inform
+ (package
+ (name "python-inform")
+ (version "1.23.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "inform" version))
+ (sha256
+ (base32
+ "0dvc5klbnbryrvspp45nmlg02g40j7xspcz7lqsm0c0dj0z29zdz"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; PyPI tarball lacks tests
+ (native-inputs
+ `(("python-hypothesis" ,python-hypothesis)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (propagated-inputs
+ `(("python-arrow" ,python-arrow)
+ ("python-six" ,python-six)))
+ (home-page "https://inform.readthedocs.io")
+ (synopsis "Print & logging utilities for communicating with user")
+ (description
+ "Inform is designed to display messages from programs that are typically run from
+a console. It provides a collection of ‘print’ functions that allow you to simply and
+cleanly print different types of messages.")
+ (license license:gpl3+)))