summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-06-29 15:11:11 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-07-05 10:14:24 +0300
commitcec2e07ec59cd6a13308de5863e7d3b87ebff5dd (patch)
treecea09cf557ba494b13b7120c6e3b6504c0494d4a /gnu/packages/python-xyz.scm
parent29b2e67d646c1982c1d4f5b8a6ba0c62f04f7bdb (diff)
gnu: python2-ipython: Remove package.
Commit a0a8fdeaf2db2695dd7944ee7d2e5eeade9e600b removed the variable 'python2-jupyer-core' which breaks the dependency 'python2-nbformat'. * gnu/packages/python-xyz.scm (python2-ipython): Remove variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm64
1 files changed, 0 insertions, 64 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7ef63a19aa..819ad26e3e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8077,70 +8077,6 @@ callback signature using a prototype function.")
Powerful interactive shells, a browser-based notebook, support for interactive
data visualization, embeddable interpreters and tools for parallel
computing.")
- (properties `((python2-variant . ,(delay python2-ipython))))
- (license license:bsd-3)))
-
-;; This is the latest release of the LTS version of ipython with support for
-;; Python 2.7 and Python 3.x. Later non-LTS versions starting from 6.0 have
-;; dropped support for Python 2.7.
-(define-public python2-ipython
- (package
- (name "python2-ipython")
- (version "5.8.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "ipython" version ".tar.gz"))
- (sha256
- (base32 "01l93i4hspf0lvhmycvc8j378bslm9rw30mwfspsl6v1ayc69b2b"))))
- (build-system python-build-system)
- (propagated-inputs
- `(("python2-backports-shutil-get-terminal-size"
- ,python2-backports-shutil-get-terminal-size)
- ("python2-pathlib2" ,python2-pathlib2)
- ("python2-pyzmq" ,python2-pyzmq)
- ("python2-prompt-toolkit" ,python2-prompt-toolkit-1)
- ("python2-terminado" ,python2-terminado)
- ("python2-matplotlib" ,python2-matplotlib)
- ("python2-numpy" ,python2-numpy)
- ("python2-numpydoc" ,python2-numpydoc)
- ("python2-jinja2" ,python2-jinja2)
- ("python2-mistune" ,python2-mistune)
- ("python2-pexpect" ,python2-pexpect)
- ("python2-pickleshare" ,python2-pickleshare)
- ("python2-simplegeneric" ,python2-simplegeneric)
- ("python2-jsonschema" ,python2-jsonschema)
- ("python2-traitlets" ,python2-traitlets)
- ("python2-nbformat" ,python2-nbformat)
- ("python2-pygments" ,python2-pygments)))
- (inputs
- `(("readline" ,readline)
- ("which" ,which)))
- (native-inputs
- `(("graphviz" ,graphviz)
- ("pkg-config" ,pkg-config)
- ("python2-requests" ,python2-requests) ;; for tests
- ("python2-testpath" ,python2-testpath)
- ("python2-mock" ,python2-mock)
- ("python2-nose" ,python2-nose)))
- (arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'delete-broken-tests
- (lambda* (#:key inputs #:allow-other-keys)
- ;; These tests throw errors for unknown reasons.
- (delete-file "IPython/core/tests/test_displayhook.py")
- (delete-file "IPython/core/tests/test_magic_terminal.py")
- (delete-file "IPython/core/tests/test_profile.py")
- #t)))))
- (home-page "https://ipython.org")
- (synopsis "IPython is a tool for interactive computing in Python")
- (description
- "IPython provides a rich architecture for interactive computing with:
-Powerful interactive shells, a browser-based notebook, support for interactive
-data visualization, embeddable interpreters and tools for parallel
-computing.")
(license license:bsd-3)))
(define-public python-ipython-documentation