summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2020-09-16 12:19:22 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-21 23:30:43 +0200
commitde8cc74749525aa4266137c25a38d46361dacb9b (patch)
treecb4ca483acdae39cc5efecb4ac1ae39fd0f2cb17 /gnu/packages/python-xyz.scm
parent620681534a2a6f0505cb7a3e1b66e6c138b28769 (diff)
gnu: Add python-rnc2rng.
* gnu/packages/python-xyz.scm (python-rnc2rng): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 085d88da57..004f07cec2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22019,3 +22019,30 @@ By default it uses the open Python vulnerability database Safety DB.")
(description "pypandoc is a thin Python wrapper around pandoc
and pandoc-citeproc.")
(license license:expat)))
+
+(define-public python-rnc2rng
+ (package
+ (name "python-rnc2rng")
+ (version "2.6.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rnc2rng" version))
+ (sha256
+ (base32
+ "1kmp3iwxxyzjsd47j2sprd47ihhkwhb3yydih3af5bbfq0ibh1w8"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-rply" ,python-rply)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "test.py"))))))
+ (home-page "https://github.com/djc/rnc2rng")
+ (synopsis "Convert RELAX NG Compact to regular syntax")
+ (description
+ "This package provides the @command{rnc2rng} command-line tool as well as
+a Python library to convert RELAX NG schemata in Compact syntax (rnc) to
+equivalent schemata in the XML-based default RELAX NG syntax.")
+ (license license:expat)))