summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-12-28 22:32:42 +0100
committerEfraim Flashner <efraim@flashner.co.il>2021-04-01 15:14:29 +0300
commitf7c7ccde2912ce7825e3ca5ef38dd2fe9644f441 (patch)
treef90c154506ba6d9c0c0e130f39886a87857d82a7 /gnu/packages/python-xyz.scm
parentb8ebe6dee815ad5611707c29d9ffed50595fdb55 (diff)
gnu: Add python-flake8-quotes.
* gnu/packages/python-xyz.scm (python-flake8-quotes): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e24a9410f0..dac857a83d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8901,6 +8901,25 @@ first-class forward references that stub files use.")
lints.")
(license license:bsd-2)))
+(define-public python-flake8-quotes
+ (package
+ (name "python-flake8-quotes")
+ (version "3.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8-quotes" version))
+ (sha256
+ (base32
+ "0ph5s6lxgpzz4an0ax6s5xjqypqmngwr5b1i0h9pqhzghplic49z"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-flake8" ,python-flake8)))
+ (home-page "https://github.com/zheller/flake8-quotes/")
+ (synopsis "Flake8 lint for quotes")
+ (description "This package provides a Flake8 lint for quotes.")
+ (license license:expat)))
+
(define-public python-autoflake
(package
(name "python-autoflake")