summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2022-12-23 19:22:32 +0100
committerChristopher Baines <mail@cbaines.net>2023-03-01 15:14:35 +0000
commitf9abf24f242348db4af469c567f58b62cc181b2a (patch)
tree164324565cc86650f8f43ec5e668ef0e743b138a /gnu/packages/python-xyz.scm
parentf01b5299db6031174f05124b843c936388cd872a (diff)
gnu: Add python-pyee.
* gnu/packages/python-xyz.scm (python-pyee): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f1b137f867..ed1832730e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30758,6 +30758,27 @@ provide the ability to selectively apply arguments to callable objects
and to reference instance methods using weak-references.")
(license license:bsd-3)))
+(define-public python-pyee
+ (package
+ (name "python-pyee")
+ (version "9.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyee" version))
+ (sha256
+ (base32 "0cjbxbqr9f8bn2h3ra69d550qj2r1hmsgrh5nx31ywmwia9c8w17"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-typing-extensions))
+ (native-inputs (list python-twisted python-trio))
+ (home-page "https://github.com/jfhbrook/pyee")
+ (synopsis "Emit events with Python")
+ (description
+ "This package provides a port of node.js's EventEmitter to python.
+Additionally, it includes a number of subclasses useful for implementing async
+and threaded programming in python, such as async/await.")
+ (license license:expat)))
+
(define-public python-queuelib
(package
(name "python-queuelib")