summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-11 21:35:37 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-18 23:19:45 +0300
commit0aea283a65a7b0095c00abd5808523f4e02427d2 (patch)
treec8b9570cc520662b51e065e2dd07fe8908c434a4 /gnu/packages/python.scm
parent12f839fdf685e68dda8f38af1bbb192fa4199d25 (diff)
gnu: Add python-nose2.
* gnu/packages/python.scm (python-nose2): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7536259c64..d6052fa4bd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1507,6 +1507,37 @@ matching them against a list of media-ranges.")
(define-public python2-nose
(package-with-python2 python-nose))
+(define-public python-nose2
+ (package
+ (name "python-nose2")
+ (version "0.6.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nose2" version))
+ (sha256
+ (base32
+ "1x4zjq1zlyrh8b9ba0cmafd3w94pxhid408kibyjd3s6h1lap6s7"))))
+ (build-system python-build-system)
+ (arguments `(#:tests? #f)) ; 'module' object has no attribute 'collector'
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (inputs
+ `(("python-cov-core" ,python-cov-core)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/nose-devs/nose2")
+ (synopsis "Next generation of nicer testing for Python")
+ (description
+ "Nose2 is the next generation of nicer testing for Python, based on the
+plugins branch of unittest2. Nose2 aims to improve on nose by providing a
+better plugin api, being easier for users to configure, and simplifying internal
+interfaces and processes.")
+ (license license:bsd-2)))
+
+(define-public python2-nose2
+ (package-with-python2 python-nose2))
+
(define-public python-unittest2
(package
(name "python-unittest2")