summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-04-03 15:55:44 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-04-03 16:08:11 +1000
commit1804527ab0ba107ee891f2c82e5346cb7044f8a3 (patch)
treee7399592527458006727f438d5ad06b10437d3b3 /gnu/packages/python.scm
parent1ef09c0c75c61fd70a84667a845a652995b38a94 (diff)
gnu: python-lockfile Use 'python2-variant'.
* gnu/packages/python.scm (python-lockfile): Use 'python2-variant'. [properties]: New field. (python2-lockfile): Use 'strip-python2-variant'.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d79cb135e6..2f2ef2ffd9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -728,10 +728,13 @@ concepts.")
(description
"The lockfile package exports a LockFile class which provides a simple
API for locking files.")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-lockfile))))))
(define-public python2-lockfile
- (package-with-python2 python-lockfile))
+ (let ((base (package-with-python2 (strip-python2-variant python-lockfile))))
+ (package
+ (inherit base))))
(define-public python-mock
(package