summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-13 15:51:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-13 15:51:46 +0300
commit399d89b5c8cf60f0ef4f4f5e1699c5d92a51f015 (patch)
tree10489a5d019a1e2b31c564205c6e2f36da505ca4 /gnu/packages/python.scm
parent170bffff550d4121e78c5c32d2c50177fa2e4c7d (diff)
gnu: micropython: Update to 1.12.
* gnu/packages/python.scm (micropython): Update to 1.12. [arguments]: Add phase to compile mpy-cross before compiling micropython.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e2b254bf6f..45d7288817 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2015, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015, 2016 Erik Edrosa <erik.edrosa@gmail.com>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015, 2017 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2015, 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
@@ -589,7 +589,7 @@ instead of @command{python3}.")))
(define-public micropython
(package
(name "micropython")
- (version "1.11")
+ (version "1.12")
(source
(origin
(method url-fetch)
@@ -598,7 +598,7 @@ instead of @command{python3}.")))
"/micropython-" version ".tar.gz"))
(sha256
(base32
- "0px3xhw16rl0l7qifq7jw1gq92wzlnhd17dmszv9m2c3wbzs9p9f"))
+ "1fl1dm2aay23hyqbarnv69qj7z2wljcvkwmvfwfac8yadcv05zcq"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -612,7 +612,11 @@ instead of @command{python3}.")))
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'build 'prepare-build
+ (add-before 'build 'build-mpy-cross
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (with-directory-excursion "mpy-cross"
+ (apply invoke "make" make-flags))))
+ (add-after 'build-mpy-cross 'prepare-build
(lambda _
(chdir "ports/unix")
;; see: https://github.com/micropython/micropython/pull/4246