summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-04-10 21:17:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-04-10 21:17:10 +0300
commit54cd239b358f7d3fb15a0d17a96713c68c5142ec (patch)
treeff4563db41f9095bcfad6087ba26f9ef3d40c753 /gnu/packages/python.scm
parent545f4a1c3cb6a613bbeb17faeebbecaa559231fd (diff)
gnu: python-pytest-runner: Define python2-pytest-runner.
* gnu/packages/python.scm (python-pytest-runner)[properties]: Define python2-pytest-runner. [native-inputs]: Remove python-setuptools. [home-page]: Project has moved to Github. (python2-pytest-runner)[native-inputs]: Add python2-setuptools.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm18
1 files changed, 12 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2cde276b37..c3daf3156f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1597,9 +1597,7 @@ supports coverage of subprocesses.")
(source
(origin
(method url-fetch)
- (uri (string-append "https://pypi.python.org/packages/source/p/"
- "pytest-runner/pytest-runner-"
- version ".tar.gz"))
+ (uri (pypi-uri "pytest-runner" version))
(sha256
(base32
"1nwcqx0l3fv52kv8526wy8ypzghbq96c96di318d98d3wh7a8xg7"))))
@@ -1617,14 +1615,22 @@ supports coverage of subprocesses.")
#t)))))
(native-inputs
`(("python-pytest" ,python-pytest)
- ("python-setuptools" ,python-setuptools)
("python-setuptools-scm" ,python-setuptools-scm)))
- (home-page "https://bitbucket.org/pytest-dev/pytest-runner")
+ (home-page "https://github.com/pytest-dev/pytest-runner")
(synopsis "Invoke py.test as a distutils command")
(description
"This package provides a @command{pytest-runner} command that
@file{setup.py} files can use to run tests.")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-pytest-runner))))))
+
+(define-public python2-pytest-runner
+ (let ((base (package-with-python2
+ (strip-python2-variant python-pytest-runner))))
+ (package
+ (inherit base)
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base))))))
(define-public python2-pytest-runner
(package-with-python2 python-pytest-runner))