summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-19 23:22:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-19 23:25:01 +0300
commit8120205ccd4f2d835552ed3bda5e9a9a533078df (patch)
treeb88cd5cd4a46e589f7f357feb72d46bacae550e2 /gnu/packages/python.scm
parentd404a6f9711c8dcc1cc6cf55d8c07901aa450192 (diff)
gnu: python2-cov-core: Use strip-python2-variant.
* gnu/packages/python.scm (python-cov-core)[properties]: New field, declare python2-variant. (python2-cov-core): Use strip-python2-variant.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 038237d6fd..96589fc165 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2154,10 +2154,11 @@ executed.")
(description
"This is a library package for use by pytest-cov, nose-cov and nose2-cov.
It is useful for developing coverage plugins for these testing frameworks.")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-cov-core))))))
(define-public python2-cov-core
- (let ((cov-core (package-with-python2 python-cov-core)))
+ (let ((cov-core (package-with-python2 (strip-python2-variant python-cov-core))))
(package (inherit cov-core)
(native-inputs
`(("python2-setuptools" ,python2-setuptools)