summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-11-21 15:17:12 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-11-21 15:20:20 +0200
commita2aa746cfe38076b87d9cde2252904c0bddd9f9e (patch)
treedec28ddc6be854c7cd56bc9edea4668f415870fb /gnu/packages/python.scm
parent96cae1b48c12b7b5b4a68d86ac9d714cab2d9881 (diff)
gnu: python-waf: Use a proper directory structure.
Fixes <https://bugs.gnu.org/25634>. * gnu/packages/python.scm (python-waf): Replace custom 'install phase to install "waf" binary into the bin directory. Remove the 'wrap phase. * gnu/packages/video.scm (mpv)[arguments]: Adjust the 'setup-waf phase accordingly.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d87b1315e6..c3d3c02684 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5692,9 +5692,12 @@ so it might be a tiny bit slower.")
(lambda _
(invoke "python" "waf" "--version")))
(replace 'install
- (lambda _
- (copy-file "waf" %output)
- #t)))))
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "waf" (string-append out "/bin")))
+ #t))
+ ;; waf breaks when it is wrapped.
+ (delete 'wrap))))
(home-page "https://waf.io/")
(synopsis "Python-based build system")
(description