summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-13 22:43:20 +0000
committerChristopher Baines <mail@cbaines.net>2019-01-13 22:47:29 +0000
commita9883939977f5fb0bd62d1dccb1ab0a772a4b720 (patch)
treebb7e42f4c4f49cd33810194771db18170a30f100 /gnu/packages/python.scm
parent847ffe88526ccf1209ff0292fbdae9c557cf5d3f (diff)
gnu: python-2.7: Fix build.
The -j flag is passed in through #:make-flags and EXTRATESTOPTS. This is combined with the TESTOPTS, and in Python 2, that includes the -l flag by default. The -l flag, is for finding memory leaks in tests, and is incompatible with the -j flag, and the build previously failed at the start of the 'check phase. Therefore, remove the -l flag from the Python 2 testsuite, as it doesn't sound like a useful thing to do when building the package for Guix. * gnu/packages/python.scm (python-2.7): Add 'remove-findleaks-from-testopts phase.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9b43f465cc..2971dfe779 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -200,6 +200,14 @@
(guix build utils) (guix build gnu-build-system))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'remove-findleaks-from-testopts
+ (lambda _
+ (substitute* "Makefile.pre.in"
+ ;; -l which is short for --findleaks isn't compatible with the
+ ;; -j flag added through the #:make-flags, therefore remove
+ ;; it. This only affects python-2.7.
+ (("TESTOPTS= -l ") "TESTOPTS= "))
+ #t))
(add-before
'configure 'patch-lib-shells
(lambda _