summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-29 20:17:42 +0200
committerMarius Bakke <marius@gnu.org>2020-06-30 21:30:52 +0200
commitc8a4e59ac4bafcb06d3f49794aabd11fa0352880 (patch)
tree50317df02a55fbbfeddb0f821961991c39741ced /gnu/packages/python.scm
parentefc396ef3d34f0f4960bfcb480c08e989d9e5353 (diff)
gnu: Python: Support cross-compiling for the Hurd.
* gnu/packages/python.scm (python-3.8): When cross-compiling for Hurd, add substitution for the configure script.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9469f89bcf..e2b254bf6f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -401,6 +401,17 @@ data types.")
,@(if (hurd-system?)
`((delete 'patch-regen-for-hurd)) ;regen was removed after 3.5.9
'())
+ ,@(if (hurd-target?)
+ ;; The build system refuses to cross-compile for unknown targets
+ ;; even though it works fine. Add GNU/Hurd target.
+ ;; TODO: Make it a patch in a future rebuild cycle.
+ '((add-before 'configure 'support-hurd-cross-compile
+ (lambda _
+ (substitute* "configure"
+ (("\\*-\\*-vxworks.*" all)
+ (string-append "*-*-gnu)\nac_sys_system=GNU\n;;\n" all)))
+ #t)))
+ '())
(add-before 'check 'set-TZDIR
(lambda* (#:key inputs native-inputs #:allow-other-keys)
;; test_email requires the Olson time zone database.