summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-02-27 14:40:21 +0100
committerLudovic Courtès <ludo@gnu.org>2015-02-27 15:08:37 +0100
commitda6dd842d038aa0761918305953ad92951fb663f (patch)
tree0f3642682b8768306b9ebb8c94d4abf790aaf23c /gnu/packages/python.scm
parente8c9f0498f9f3ead4ea345d49f1c5e630ff158f8 (diff)
gnu: Remove now unneeded 'unpack' phases for unzip.
This is a followup to commit cd0385b. * gnu/packages/bioinformatics.scm (hisat)[arguments]: Remove 'unpack' phase. * gnu/packages/image.scm (freeimage): Likewise. * gnu/packages/python.scm (python2-cssutils): Likewise.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index bbff241833..0df91d69cb 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
@@ -3129,13 +3129,7 @@ capabilities to the Python interpreter.")
(arguments
`(#:python ,python-2 ; Otherwise tests fail with a syntax error.
#:tests? #f ; The tests apparently download an external URL.
- #:phases
- (alist-replace
- 'unpack
- (lambda* (#:key source #:allow-other-keys)
- (and (zero? (system* "unzip" source))
- (chdir "cssutils-1.0")))
- %standard-phases)))
+ ))
(home-page "http://cthedot.de/cssutils/")
(synopsis
"CSS Cascading Style Sheets library for Python")