summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-01 23:15:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-02 06:44:36 +0300
commitfc1a170e65d721ed4cea35fdd4752678c21d5741 (patch)
tree30e7eff876bd5fcf1dee67c4b9da6bf6aa673924 /gnu/packages/python.scm
parent2b031d3fc109c5b726d0711d948ee465f662f0a4 (diff)
gnu: python2-numexpr: Use strip-python2-variant.
* gnu/packages/python.scm (python2-numexpr): Replace package definition with 'package-with-python2', using 'strip-python2-variant'.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index dd59be8f02..6e2c865f0e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3303,17 +3303,11 @@ doing the same calculation in Python. In addition, its multi-threaded
capabilities can make use of all your cores, which may accelerate
computations, most specially if they are not memory-bounded (e.g. those using
transcendental functions).")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-numexpr))))))
(define-public python2-numexpr
- (let ((numexpr (package-with-python2 python-numexpr)))
- (package (inherit numexpr)
- ;; Make sure to use special packages for Python 2 instead
- ;; of those automatically rewritten by package-with-python2.
- (propagated-inputs
- `(("python2-numpy" ,python2-numpy)
- ,@(alist-delete "python-numpy"
- (package-propagated-inputs numexpr)))))))
+ (package-with-python2 (strip-python2-variant python-numexpr)))
(define-public python-matplotlib
(package