summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-27 16:09:51 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 20:17:12 -0400
commit03094173be7ae1bb4c9c074cbb70b8940fbaa057 (patch)
treebacaf1c030590d2e2f0a3155ee7d2a5a6ea42de6 /gnu/packages/qt.scm
parent7d3c654936f603fc1988652f5e7774e0fcd87313 (diff)
gnu: qtlocation: Update to 5.15.5.
* gnu/packages/qt.scm (qtlocation): Update to 5.15.5. [arguments]: Use gexps.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 08b791f9bf..ca0614af4b 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1869,27 +1869,26 @@ application without necessarily including a full web browser stack by using
native APIs where it makes sense.")))
(define-public qtlocation
- (package (inherit qtsvg-5)
+ (package
+ (inherit qtsvg-5)
(name "qtlocation")
(version "5.15.5")
(source (origin
- (method url-fetch)
- (uri (qt-urls name version))
- (sha256
- (base32
- "0mlhhhcxx3gpr9kh04c6fljxcj50c2j21r0wb9f7d7nk4flip7b2"))))
+ (method url-fetch)
+ (uri (qt-urls name version))
+ (sha256
+ (base32
+ "0mlhhhcxx3gpr9kh04c6fljxcj50c2j21r0wb9f7d7nk4flip7b2"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg-5)
- ((#:tests? _ #f) #f) ; TODO: Enable the tests
+ ((#:tests? _ #f) #f) ; TODO: Enable the tests
((#:phases phases)
- `(modify-phases ,phases
- (add-before 'check 'pre-check
- (lambda _
- (setenv "HOME" "/tmp")))))))
- (native-inputs
- (list perl qtdeclarative-5 qtquickcontrols-5 qtserialport))
- (inputs
- (list icu4c openssl qtbase-5 zlib))
+ #~(modify-phases #$phases
+ (add-before 'check 'pre-check
+ (lambda _
+ (setenv "HOME" "/tmp")))))))
+ (native-inputs (list perl qtdeclarative-5 qtquickcontrols-5 qtserialport))
+ (inputs (list icu4c openssl qtbase-5 zlib))
(synopsis "Qt Location and Positioning modules")
(description "The Qt Location module provides an interface for location,
positioning and geolocation plugins.")))