summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-27 16:09:53 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:11:44 -0400
commita3041f53e78a345ae502c2bf64bbc4f579c40405 (patch)
tree5893614954754880002c1fef1ca7f8ffb35d100a /gnu/packages/qt.scm
parent63f5485616127d5d991c36f0594bf47100e36ef5 (diff)
gnu: qtscxml: Update to 5.15.8.
* gnu/packages/qt.scm (qtscxml): Update to 5.15.8.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm37
1 files changed, 18 insertions, 19 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 976829e643..7e1864b55e 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2123,27 +2123,26 @@ primary target audience are embedded devices with fullscreen user interfaces,
and mobile applications targeting TV-like form factors.")))
(define-public qtscxml
- (package (inherit qtsvg-5)
+ (package
+ (inherit qtsvg-5)
(name "qtscxml")
- (version "5.15.5")
+ (version "5.15.8")
(source (origin
- (method url-fetch)
- (uri (qt-urls name version))
- (sha256
- (base32
- "0xf5mqsrw16h8xjglymgfc8qg2qa5bi4fgdl4j3dkhvvpr7vrphp"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (delete-file-recursively "tests/3rdparty")
- ;; the scion test refers to the bundled 3rd party test code.
- (substitute* "tests/auto/auto.pro"
- (("scion") "#"))))))
- (arguments
- (substitute-keyword-arguments (package-arguments qtsvg-5)
- ((#:tests? _ #f) #f))) ; TODO: Enable the tests
- (inputs
- (list qtbase-5 qtdeclarative-5))
+ (method url-fetch)
+ (uri (qt-urls name version))
+ (sha256
+ (base32
+ "17j6npvgr8q3lyrqmvfh1n47mkhfzk18r998hcjm2w75xj46km1n"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "tests/3rdparty")
+ ;; the scion test refers to the bundled 3rd party test code.
+ (substitute* "tests/auto/auto.pro"
+ (("scion") "#"))))))
+ (arguments (substitute-keyword-arguments (package-arguments qtsvg-5)
+ ((#:tests? _ #f) #f))) ; TODO: Enable the tests
+ (inputs (list qtbase-5 qtdeclarative-5))
(synopsis "Qt SCXML module")
(description "The Qt SCXML module provides functionality to create state
machines from SCXML files. This includes both dynamically creating state