summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-02-17 14:17:55 -0500
committerLeo Famulari <leo@famulari.name>2023-02-17 14:49:13 -0500
commitabe7afb17ced298743f3eca2fa156d480fdd038d (patch)
tree733e5ae8bd843f405c4f9af243ad16b6c330f20c /gnu/packages/qt.scm
parent7eb3eec4dacc414a6680a97bc6ef38c1f76b947e (diff)
gnu: Make nothing depend on QtWebKit.
This is required for <https://issues.guix.gnu.org/53289>. * gnu/packages/qt.scm (python-pyqt)[inputs]: Remove qtwebkit. (python-pyqt-without-qtwebkit): Remove variable. (python-pyqtwebengine)[inputs]: Replace python-pyqt-without-qtwebkit with python-pyqt. * gnu/packages/backup.scm (vorta)[inputs]: Likewise. * gnu/packages/ebook.scm (calibre)[inputs]: Likewise. [arguments]: Adjust accordingly. * gnu/packages/education.scm (anki)[inputs]: Replace python-pyqt-without-qtwebkit with python-pyqt. * gnu/packages/kde-games.scm (kajongg)[inputs]: Likewise. * gnu/packages/maths.scm (veusz)[inputs]: Likewise. * gnu/packages/music.scm (frescobaldi)[inputs]: Likewise. (picard)[inputs]: Likewise. * gnu/packages/orange.scm (orange)[inputs]: Likewise. * gnu/packages/pdf.scm (flyer-composer)[inputs]: Likewise. * gnu/packages/python-check.scm (python-pytest-qt)[propagated-inputs]: Likewise. * gnu/packages/python-xyz.scm (python-qtconsole)[propagated-inputs]: Likewise. (python-pyqtgraph)[propagated-inputs]: Likewise. * gnu/packages/radio.scm (gnuradio)[inputs]: Likewise. * gnu/packages/video.scm (openshot)[inputs]: Likewise. * gnu/packages/vpn.scm (openconnect-sso)[inputs]: Likewise. * gnu/packages/web-browsers.scm (qutebrowser)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index da18395efc..cad07ea19d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -3270,7 +3270,6 @@ module provides support functions to the automatically generated code.")
("qtsvg-5" ,qtsvg-5)
("qttools-5" ,qttools-5)
("qtwebchannel-5" ,qtwebchannel-5)
- ("qtwebkit" ,qtwebkit)
("qtwebsockets-5" ,qtwebsockets-5)
("qtx11extras" ,qtx11extras)
("qtxmlpatterns" ,qtxmlpatterns)))
@@ -3367,7 +3366,7 @@ contain over 620 classes.")
(inputs
`(("python" ,python-wrapper)
("python-sip" ,python-sip)
- ("python-pyqt" ,python-pyqt-without-qtwebkit)
+ ("python-pyqt" ,python-pyqt)
("qtbase" ,qtbase-5)
("qtsvg-5" ,qtsvg-5)
("qtdeclarative-5" ,qtdeclarative-5)
@@ -3425,17 +3424,6 @@ set of three modules. Prior to v5.12 these bindings were part of PyQt
itself.")
(license license:gpl3)))
-;; XXX: This is useful for removing qtwebkit from other packages' dependency
-;; graphs, as well as for preventing python-pyqtwebengine from transitively
-;; depending on qtwebkit.
-;; Ultimately, it would be nicer to have a more modular set of python-pyqt-*
-;; packages that could be used together.
-(define-public python-pyqt-without-qtwebkit
- (package/inherit python-pyqt
- (name "python-pyqt-without-qtwebkit")
- (inputs
- (alist-delete "qtwebkit" (package-inputs python-pyqt)))))
-
(define-public python-pyqt-builder
(package
(name "python-pyqt-builder")