summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-23 15:42:07 +0200
committerMarius Bakke <marius@gnu.org>2020-05-26 22:36:12 +0200
commitc37b621cf3f0cd9c06677b4be6f931d927e7fea5 (patch)
tree2050a1b01ce47cdb6a9e65d048dbaae1c6e4c7cd /gnu/packages/qt.scm
parentcb475eaa71734351acae60e14c4d318d050da64b (diff)
gnu: qtwebengine: Fix build failure.
* gnu/packages/qt.scm (qtwebengine)[source](snippet): Preserve the included Mesa headers, to avoid an incompatibility with system Mesa. Also adjust some files to use system Vulkan headers. Preserve third_party/emoji-segmenter. [inputs]: Remove obsolete comment (LCMS is already in inputs).
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 0c3a680484..d22c84fcf3 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1595,6 +1595,7 @@ message.")))
"third_party/crc32c"
"third_party/dav1d"
"third_party/dawn"
+ "third_party/emoji-segmenter"
"third_party/ffmpeg"
"third_party/googletest"
"third_party/hunspell"
@@ -1621,6 +1622,7 @@ message.")))
"third_party/libyuv"
"third_party/lss"
"third_party/markupsafe"
+ "third_party/mesa_headers"
"third_party/metrics_proto"
"third_party/modp_b64"
"third_party/nasm"
@@ -1737,6 +1739,12 @@ message.")))
(substitute*
"third_party/breakpad/breakpad/src/common/linux/libcurl_wrapper.h"
(("third_party/curl") "curl"))
+ (substitute*
+ '("components/viz/common/gpu/vulkan_context_provider.h"
+ "components/viz/common/resources/resource_format_utils.h"
+ "gpu/config/gpu_util.cc")
+ (("third_party/vulkan/include/")
+ ""))
;; Replace Google Analytics bundle with an empty file and hope
;; no one notices.
@@ -1777,8 +1785,6 @@ message.")))
("libgcrypt" ,libgcrypt)
("libjpeg" ,libjpeg-turbo)
("libvpx" ,libvpx)
- ;; FIXME: configure does not find system lcms
- ;; ("lcms" ,lcms)
("libwebp" ,libwebp)
("libx11" ,libx11)
("libxcb" ,libxcb)