summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-03-29 17:31:57 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-03-29 19:39:18 +0200
commit9aaeb9bd957daa988a63ddddee8f4e7efdd7d979 (patch)
treedf860c7521151435140e571a1bcbdc1bcbdce988 /gnu/packages/radio.scm
parent692c75eaa6c87c73ad2e20cbded6c32b9ae6b8a2 (diff)
gnu: wsjtx-hamlib: Update to 2.3.1.
* gnu/packages/radio.scm (wsjtx-hamlib): Update to 2.3.1. [arguments]: Remove alleged 'fix-tests phase.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index c10c91fd99..d669c43c87 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -844,7 +844,7 @@ users.")
(package
(inherit hamlib)
(name "wsjtx-hamlib")
- (version "2.3.0")
+ (version "2.3.1")
(source
(origin
(method git-fetch)
@@ -853,7 +853,7 @@ users.")
(commit (string-append "wsjtx-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0ampwqs7p0g8pdnwpdrbvwyqag065n96amgb3v4z332nw0nxvm10"))))
+ (base32 "0m4yzjcqs7a1w4lghyyckpkiy96jxdjijddxarqr3a37cl2rz23j"))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -865,15 +865,7 @@ users.")
"--with-lua-binding"
"--with-python-binding"
"--with-tcl-binding"
- "--with-xml-support")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-tests
- (lambda _
- (substitute* "tests/testloc.c"
- (("dmmm2dec\\(deg, mmm, nesw\\);")
- "dmmm2dec(deg, mmm, 0, nesw);"))
- #t)))))))
+ "--with-xml-support")))))
(define-public wsjtx
(package