summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-26 02:51:50 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-26 02:52:34 +0200
commit11afd465196d8eaf272812d9752fdadd30b82bb1 (patch)
tree3d7fddf0a60eefe6de12c2e36a82f865d8a25f2a /gnu/packages/ruby.scm
parent900c2ca8f7fd9b71fcb7ee5d111b1975d660e853 (diff)
gnu: ruby-stackprof: Build (more) reliably.
* gnu/packages/ruby.scm (ruby-stackprof)[arguments]: Add a new 'skip-dubious-test phase.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6f6bd9e1bf..14197e1eab 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7731,6 +7731,12 @@ navigation capabilities to @code{pry}, using @code{byebug}.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-before 'check 'skip-dubious-test
+ ;; This unreliable test can fail with "Expected 0 to be >= 1."
+ (lambda _
+ (substitute* "test/test_stackprof.rb"
+ (("def test_(cputime)" _ name)
+ (string-append "def skip_" name)))))
(add-before 'check 'build-tests
(lambda _
(invoke "rake" "compile"))))))