summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-08-10 14:25:16 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-08-10 15:36:33 +1000
commit3840373b399d1d6877a414a44c28d1bb12c0cb9e (patch)
tree3b86ab168e5eacd1614504d98f11fc4cf816f214 /gnu/packages/ruby.scm
parent10fa1d98e19c5fbdf36f4748f759fea4daff8ca4 (diff)
gnu: ruby-puma: Update to 3.6.0.
* gnu/packages/ruby.scm (ruby-puma): Update to 3.6.0. [arguments]: Add 'delete-integration-tests' phase. (gnu/packages/patches/ruby-puma-ignore-broken-test.patch): Remove only one broken test.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0ff7d5625c..21ca2f2c7c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3953,7 +3953,7 @@ part of the Prawn PDF generator.")
(define-public ruby-puma
(package
(name "ruby-puma")
- (version "3.4.0")
+ (version "3.6.0")
(source
(origin
(method url-fetch)
@@ -3963,14 +3963,22 @@ part of the Prawn PDF generator.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "10svyj2jk949y1dmkxyzipk1ddzl4iz9limrcws1zhpganpvq3j8"))
- ;; Ignore broken test reported upstream.
+ "08aws79n9slcr50d9lwm011cp1pxvr1409c2jmyjxywvrc0a30v1"))
+ ;; Ignore broken tests reported upstream.
;; https://github.com/puma/puma/issues/995
+ ;; https://github.com/puma/puma/issues/1044
(patches (search-patches "ruby-puma-ignore-broken-test.patch"))))
(build-system ruby-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'delete-integration-tests
+ (lambda _
+ ;; One broken test in this file cannot be easily removed in
+ ;; isolation, it probably causes race conditions. So we delete
+ ;; the entire file.
+ (delete-file "test/test_integration.rb")
+ #t))
(add-before 'build 'fix-gemspec
(lambda _
(substitute* "puma.gemspec"