summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-15 01:09:18 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-17 23:01:32 -0400
commit8aba0333b25006e4e09f7cb2b817eea12c4d77a8 (patch)
treeda488406dd2f80af208a2f8679cad3c12c4d5952 /gnu/packages/ruby.scm
parentac75f1df1d41249260c1599d8d62871189382bb0 (diff)
gnu: Add ruby-regexp-property-values.
* gnu/packages/ruby.scm (ruby-regexp-property-values): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index cf500c8efe..d0c6ccb9c1 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6557,6 +6557,37 @@ following: @code{[1, 2, 3, 4, 6, 8, 9, 10]} into @code{[1..4, 6..6, 8..10]}.")
(home-page "https://github.com/janosch-x/range_compressor")
(license license:expat)))
+(define-public ruby-regexp-property-values
+ (package
+ (name "ruby-regexp-property-values")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference ;no test suite in distributed gem
+ (url "https://github.com/jaynetics/regexp_property_values.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0l3fjmscg1wxn7kc6bl022cc6k5d91pwb7daq1b5w36kvsx52w1j"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:test-target "default"))
+ (native-inputs
+ `(("ruby-character-set" ,ruby-character-set)
+ ("ruby-rake-compiler" ,ruby-rake-compiler)
+ ("ruby-range-compressor" ,ruby-range-compressor)
+ ("ruby-rspec" ,ruby-rspec)))
+ (synopsis "Inspect Ruby's regex engine property values")
+ (description "This small library lets you see which property values are
+supported by the regular expression engine of the Ruby version you are running
+and can directly read out their code point ranges. In other words, it
+determines all supported values for @code{\\p{value}} expressions and what
+they match.")
+ (home-page "https://github.com/jaynetics/regexp_property_values")
+ (license license:expat)))
+
(define-public ruby-rubocop
(package
(name "ruby-rubocop")