summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-15 01:08:57 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-17 23:01:31 -0400
commit93ec41c648ced0c3606923366a3658d335148b11 (patch)
treee71abbe05ce168825f483a6d2520f640024f9208 /gnu/packages/ruby.scm
parente098bdae3acdb024f0d73ac4245402811c644dac (diff)
gnu: Add ruby-character-set.
* gnu/packages/ruby.scm (ruby-character-set): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ad1692f4b9..3c3da2a625 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6495,6 +6495,35 @@ parsing.")
(home-page "https://github.com/ruby/rexml")
(license license:bsd-2)))
+(define-public ruby-character-set
+ (package
+ (name "ruby-character-set")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "character_set" version))
+ (sha256
+ (base32
+ "0affq9n77vwy897ri2zhmfinfagf37hcwwimrccy1bcxan9mj3h3"))))
+ (build-system ruby-build-system)
+ (arguments '(#:tests? #f)) ;avoid a cycle with ruby-regexp-parser
+ (synopsis "Ruby library to manipulate Unicode")
+ (description "CharacterSet is a C-extended Ruby library to work with sets
+of Unicode code points. It can read and write these sets in various formats
+and implements the @code{stdlib} @code{Set} interface for them. It also
+offers an alternate paradigm of @code{String} processing which grants much
+better performance than @code{Regexp} and @code{String} methods from the
+@code{stdlib} where applicable. Many parts can be used independently, e.g.:
+@itemize
+@item @code{CharacterSet::Character}
+@item @code{CharacterSet::Parser}
+@item @code{CharacterSet::Writer}
+@item @code{RangeCompressor}
+@end itemize")
+ (home-page "https://github.com/jaynetics/character_set")
+ (license license:expat)))
+
(define-public ruby-rubocop
(package
(name "ruby-rubocop")