summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-07-01 10:07:26 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:26:03 +0100
commitd0d3c6c914777b2094dab378d11c6236dae44dc5 (patch)
treea76918f9beee4316b29645631f77c23ac1932638 /gnu/packages/ruby.scm
parent135c9af111d3035dc8ea491afdcbb336016f61b5 (diff)
gnu: Add ruby-hoe-3.
Some packages tests fail due to Hoe not parsing the README, so this provides a way around that. * gnu/packages/ruby.scm (ruby-hoe-3): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1a9a27a03e..ee027d7da1 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -406,6 +406,17 @@ announcement.")
(home-page "https://www.zenspider.com/projects/hoe.html")
(license license:expat)))
+(define-public ruby-hoe-3
+ (package
+ (inherit ruby-hoe)
+ (version "3.26.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "hoe" version))
+ (sha256
+ (base32
+ "02vmphnfzna1dbb1l5nczcvlvvsg4flr26bdhmvdyf447bpswa63"))))))
+
(define-public ruby-rake-compiler
(package
(name "ruby-rake-compiler")