summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-29 11:16:36 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:37 +0200
commit10ad89189c88aebd68240129dbae7947a9b2ccca (patch)
treeeba72516930d2bc727a948693cd4b761fb718bb3 /gnu/packages/rust-apps.scm
parentda3cec83ae18aa6ead0b10a815b12fb618eee7b1 (diff)
gnu: rust-xremap: Update to 0.8.14.
* gnu/packages/rust-apps.scm (rust-xremap): Update to 0.8.14. [cargo-inputs]: Add rust-toml-0.8. Replace rust-x11rb-0.12 with 0.13. Change-Id: I9d3356aaac04b09cfa51013075181cb5b4d74e0b
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index e92d902594..5f84a60800 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2712,7 +2712,7 @@ advanced keybindings, word-level diff highlighting, syntax highlighting for
(define-public rust-xremap
(package
(name "rust-xremap")
- (version "0.8.9")
+ (version "0.8.14")
(source
(origin
(method url-fetch)
@@ -2720,7 +2720,7 @@ advanced keybindings, word-level diff highlighting, syntax highlighting for
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1815hz1a93brj6v9102xypds1qslf6gxgk9vcvxhxlhy1c2pfxvj"))))
+ "1691clzqbwcywz66k0lf5wjz3q5cpbks0l090bfv42idzr5a0ghl"))))
(build-system cargo-build-system)
(arguments
`(#:features '()
@@ -2744,9 +2744,10 @@ advanced keybindings, word-level diff highlighting, syntax highlighting for
("rust-serde-with" ,rust-serde-with-3)
("rust-serde-yaml" ,rust-serde-yaml-0.9)
("rust-swayipc" ,rust-swayipc-3)
+ ("rust-toml" ,rust-toml-0.8)
("rust-wayland-client" ,rust-wayland-client-0.30)
("rust-wayland-protocols-wlr" ,rust-wayland-protocols-wlr-0.1)
- ("rust-x11rb" ,rust-x11rb-0.12)
+ ("rust-x11rb" ,rust-x11rb-0.13)
("rust-zbus" ,rust-zbus-1))
#:phases
(modify-phases %standard-phases