summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorSimon Streit <simon@netpanic.org>2022-08-08 16:56:42 +0200
committerLars-Dominik Braun <lars@6xq.net>2022-09-24 09:41:24 +0200
commit14359befa92d2d54af0e584724610d8a31f5ac63 (patch)
tree489f38bca2a2b7026298352ad8a9df4d609eb35c /gnu/packages/samba.scm
parentd68721c55ae683d5939d1cf88f15081aa97c2b2b (diff)
gnu: Add wsdd.
* gnu/packages/samba.scm (wsdd): New variable. Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index c393dd6f65..e4f2c0e20e 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -36,6 +36,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system copy)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
#:use-module (gnu packages)
@@ -508,3 +509,30 @@ and IPV6 and the protocols layered above them, such as TCP and UDP.")
license:bsd-4
license:gpl2+
license:public-domain))))
+
+(define-public wsdd
+ (package
+ (name "wsdd")
+ (version "0.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference (url "https://github.com/christgau/wsdd")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04an2w6hamnai668ag4vq8x0i09fsg2jrayb4a7ar0x6bn837k7m"))))
+ (build-system copy-build-system)
+ (inputs
+ `(("python" ,python)))
+ (arguments
+ '(#:install-plan
+ '(("src/wsdd.py" "bin/wsdd")
+ ("man/wsdd.1" "share/man/man1/"))))
+ (home-page "https://github.com/christgau/wsdd")
+ (synopsis "A Web Service Discovery host daemon")
+ (description "This daemon allows (Samba) hosts to be found by Web
+Service Dicovery Clients. It also implements the client side of the
+discovery protocol which allows to search for devices implementing
+WSD.")
+ (license license:expat)))