summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-02-22 00:29:54 +0100
committerLudovic Courtès <ludo@gnu.org>2016-02-22 00:36:24 +0100
commit95001d4b4677b64f26a4bf202a77267830bb7039 (patch)
tree325e3d78611aee8e2ec0b8f39fca268e39215742 /gnu/packages/scheme.scm
parent49e0ca90bcccf01eca34b1e781b70b1560915c57 (diff)
download: Add 'url-fetch/tarbomb'.
Suggested by Federico Beffa. Fixes <http://bugs.gnu.org/22676>. Reported by Danny Milosavljevic <dannym@scratchpost.org>. * gnu/packages/engineering.scm (broken-tarball-fetch): Remove. (fastcap)[source](method): Use URL-FETCH/TARBOMB instead. * gnu/packages/scheme.scm (broken-tarball-fetch): Remove. (scmutils)[source](method): Use URL-FETCH/TARBOMB instead. * guix/download.scm (url-fetch/tarbomb): New procedure, renamed from 'broken-tarball-fetch'.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 352b66c59b..00b573fc0b 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -526,12 +526,6 @@ an isolated heap allowing multiple VMs to run simultaneously in different OS
threads.")
(license bsd-3)))
-;; FIXME: This function is temporarily in the engineering module and not
-;; exported. It will be moved to an utility module for general use. Once
-;; this is done, we should remove this definition.
-(define broken-tarball-fetch
- (@@ (gnu packages engineering) broken-tarball-fetch))
-
(define-public scmutils
(let ()
(define (system-suffix)
@@ -546,7 +540,7 @@ threads.")
(version "20140302")
(source
(origin
- (method broken-tarball-fetch)
+ (method url-fetch/tarbomb)
(modules '((guix build utils)))
(snippet
;; Remove binary code