summaryrefslogtreecommitdiff
path: root/gnu/packages/selinux.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-13 13:37:33 +0200
committerMarius Bakke <marius@gnu.org>2022-08-13 19:24:35 +0200
commit86084aa4c8ecbedbb946bca97df17de2c1995970 (patch)
treebb9b22376e1696fc45128767516d1306e5aebaec /gnu/packages/selinux.scm
parent0d79288fb6d8b27b235693374c6eaea4cdd38c80 (diff)
gnu: checkpolicy: Remove input labels.
* gnu/packages/selinux.scm (checkpolicy)[arguments]: Use G-expression & SERACH-INPUT-FILE. [native-inputs, inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/selinux.scm')
-rw-r--r--gnu/packages/selinux.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/selinux.scm b/gnu/packages/selinux.scm
index fd1c79a9ab..18422ffe2e 100644
--- a/gnu/packages/selinux.scm
+++ b/gnu/packages/selinux.scm
@@ -23,6 +23,7 @@
(define-module (gnu packages selinux)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (guix gexp)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix utils)
@@ -100,25 +101,24 @@ boolean settings).")
(package/inherit libsepol
(name "checkpolicy")
(arguments
- `(#:tests? #f ; there is no check target
- #:make-flags
- (let ((out (assoc-ref %outputs "out")))
- (list (string-append "PREFIX=" out)
- (string-append "LIBSEPOLA="
- (assoc-ref %build-inputs "libsepol")
- "/lib/libsepol.a")
- (string-append "CC=" ,(cc-for-target))))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'portability)
- (add-after 'unpack 'enter-dir
- (lambda _ (chdir ,name))))))
+ (list
+ #:tests? #f ; there is no check target
+ #:make-flags
+ #~(list (string-append "PREFIX=" #$output)
+ (string-append "LIBSEPOLA="
+ (search-input-file %build-inputs
+ "/lib/libsepol.a"))
+ (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'portability)
+ (add-after 'unpack 'enter-dir
+ (lambda _ (chdir #$name))))))
(inputs
- `(("libsepol" ,libsepol)))
+ (list libsepol))
(native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)))
+ (list bison flex))
(synopsis "Check SELinux security policy configurations and modules")
(description
"This package provides the tools \"checkpolicy\" and \"checkmodule\".