summaryrefslogtreecommitdiff
path: root/gnu/packages/shellutils.scm
diff options
context:
space:
mode:
authorArtem Chernyak <artemchernyak@gmail.com>2021-10-04 21:08:46 -0500
committerLudovic Courtès <ludo@gnu.org>2021-10-18 10:13:18 +0200
commitf5a7a42da82055c316aadf2d736857de2b0ab34a (patch)
treebcd6c6690c914511d692c6a53bbd5794b94c1b94 /gnu/packages/shellutils.scm
parent0d2400ceca8d0a0358abaf4cd699e54ddad0e885 (diff)
gnu: direnv: Update to 2.28.0.
* gnu/packages/shellutils.scm (direnv): Update to 2.28.0. [arguments]: Remove 'delete-vendor' phase, which is no longer needed. In 'check' phase, run "go test". [native-inputs]: Add GO-GITHUB-COM-MATTN-GO-ISATTY and GO-GOLANG-ORG-X-MOD. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/shellutils.scm')
-rw-r--r--gnu/packages/shellutils.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 9a364d0ade..70236d9e5c 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -292,7 +292,7 @@ are already there.")
(define-public direnv
(package
(name "direnv")
- (version "2.15.2")
+ (version "2.28.0")
(source
(origin (method git-fetch)
(uri (git-reference
@@ -301,18 +301,12 @@ are already there.")
(file-name (git-file-name name version))
(sha256
(base32
- "1y18619pmhfl0vrf4w0h75ybkkwgi9wcb7d9kv4n8drg1xp4aw4w"))))
+ "0yk53jn7wafklixclka17wyjjs2g5giigjr2bd0xzy10nrzwp7c9"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/direnv/direnv"
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'delete-vendor
- (lambda _
- ;; Using a snippet causes issues with the name of the directory,
- ;; so delete the extra source code here.
- (delete-file-recursively "src/github.com/direnv/direnv/vendor")
- #t))
(add-after 'install 'install-manpages
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -330,7 +324,9 @@ are already there.")
;; The following file needs to be writable so it can be
;; modified by the testsuite.
(make-file-writable "test/scenarios/base/.envrc")
- (invoke "make" "test")
+ ;; We need to manually run test because make test
+ ;; tries to use go modules
+ (invoke "go" "test" "./...")
;; Clean up from the tests, especially so that the extra
;; direnv executable that's generated is removed.
(invoke "make" "clean")))
@@ -338,6 +334,8 @@ are already there.")
(native-inputs
`(("go-github-com-burntsushi-toml" ,go-github-com-burntsushi-toml)
("go-github-com-direnv-go-dotenv" ,go-github-com-direnv-go-dotenv)
+ ("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)
+ ("go-golang-org-x-mod" ,go-golang-org-x-mod)
("which" ,which)))
(home-page "https://direnv.net/")
(synopsis "Environment switcher for the shell")