summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-25 01:12:35 +0200
committerMarius Bakke <marius@gnu.org>2020-07-25 16:16:11 +0200
commit45f7dc37c6bbbd334bc2fed8f088f94b32971948 (patch)
tree4916a0b04764eb74ab36e261a0ddf7320aff750e /gnu/packages/sphinx.scm
parente1409c764f554b688efe07c04bf90198daeca258 (diff)
gnu: Remove python2-sphinx.
* gnu/packages/sphinx.scm (python-sphinx)[properties]: Use self as python2 variant. (python2-sphinx): Remove variable.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm47
1 files changed, 1 insertions, 46 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index f27f9d0176..2b8b15ff7d 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -99,52 +99,7 @@
for Python projects or other documents consisting of multiple reStructuredText
sources.")
(license license:bsd-2)
- (properties `((python2-variant . ,(delay python2-sphinx))))))
-
-;; Sphinx 2 does not support Python 2, so we stick with this older version here.
-;; Remove this package once python2-pbcore no longer requires it.
-(define-public python2-sphinx
- (let ((base (package-with-python2 (strip-python2-variant python-sphinx))))
- (package
- (inherit base)
- (version "1.7.7")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "Sphinx" version))
- (sha256
- (base32
- "0pkkbfj7cl157q550gcs45am5y78ps0h7q6455d64s1zmw01jlvi"))))
- (arguments
- (substitute-keyword-arguments (package-arguments base)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-before 'check 'disable-broken-tests
- (lambda _
- ;; These tests are broken when using Python2:
- ;; <https://github.com/sphinx-doc/sphinx/issues/4710>.
- (for-each delete-file '("tests/test_api_translator.py"
- "tests/test_setup_command.py"))
- #t))))))
- (native-inputs `(("python2-mock" ,python2-mock)
- ("python2-enum34" ,python2-enum34)
- ,@(package-native-inputs base)))
- ;; Sphinx 2 has some dependencies that do not support Python 2, so
- ;; we keep our own propagated-inputs here instead of inheriting.
- (propagated-inputs `(("python2-pytz" ,python2-pytz)
- ("python2-typing" ,python2-typing)
- ("python2-imagesize" ,python2-imagesize)
- ("python2-sphinx-alabaster-theme"
- ,python2-sphinx-alabaster-theme)
- ("python2-babel" ,python2-babel-2.6)
- ("python2-snowballstemmer" ,python2-snowballstemmer)
- ("python2-docutils" ,python2-docutils-0.14)
- ("python2-jinja2" ,python2-jinja2)
- ("python2-packaging" ,python2-packaging)
- ("python2-pygments" ,python2-pygments)
- ("python2-requests" ,python2-requests)
- ("python2-six" ,python2-six)
- ("python2-sphinxcontrib-websupport"
- ,python2-sphinxcontrib-websupport))))))
+ (properties `((python2-variant . ,(delay python-sphinx))))))
(define-public python-sphinxcontrib-applehelp
(package