summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorSimon Streit <simon@netpanic.org>2023-02-02 22:01:00 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-25 15:03:49 -0500
commit1dac5b21579cacd8d4a74bea1e181e68d412e246 (patch)
treecfa05b236a425796f3b954cacace50d5863f8331 /gnu/packages/spice.scm
parent61f691fdfb4846e123e6423ee192142a35bd114d (diff)
gnu: virglrenderer: Update to 0.10.4.
* gnu/packages/spice.scm (virglrenderer): Update to 0.10.4. [source]: Use git-fetch and update URI. [build-system] Change to meson-build-system. [inputs]: Remove eudev. [native-inputs]: Add python. [home-page]: Update URL. Co-authored-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 8d2bed38b2..f492957fb2 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -56,6 +56,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
@@ -87,22 +88,23 @@ different (virtual) machine than the one to which the USB device is attached.")
(define-public virglrenderer
(package
(name "virglrenderer")
- (version "0.7.0")
+ (version "0.10.4")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://www.freedesktop.org/software/virgl/"
- "virglrenderer-" version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/virgl/virglrenderer")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "041agg1d6i8hg250y30f08n3via0hs9rbijxdrfifb8ara805v0m"))))
- (build-system gnu-build-system)
- (inputs (list eudev libepoxy mesa))
- (native-inputs (list pkg-config))
+ "06pwavrknyhghlxyh7ckq4scjx47v9fhy08r6pn194whzvzivmqg"))))
+ (build-system meson-build-system)
+ (inputs (list libepoxy mesa))
+ (native-inputs (list pkg-config python))
(synopsis "Virtual 3D GPU library")
(description "A virtual 3D GPU library that enables a virtualized operating
system to use the host GPU to accelerate 3D rendering.")
- (home-page "https://virgil3d.github.io")
+ (home-page "https://gitlab.freedesktop.org/virgl/virglrenderer")
(license (list license:expat license:bsd-3))))
(define-public spice-protocol