summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-17 02:51:25 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-17 03:04:40 +0200
commit33c154d6a5cd4f586b833ebd5d34f4f44339b0ba (patch)
tree4851a85b917e04d4ed942fec96974aa7af5555c5 /gnu/packages/ssh.scm
parentf49eb9f997ce0eca391da00b3fc56ac474e23fe4 (diff)
gnu: corkscrew: Use git source.
* gnu/packages/ssh.scm (corkscrew)[source]: Use GIT-FETCH and GIT-FILE-NAME. [arguments]: Adapt to changed README file name. [home-page]: Switch to a working URI.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 9ae3d94194..a612b9dd15 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -401,26 +401,25 @@ libssh library.")
(version "2.0")
(source
(origin
- (method url-fetch)
- ;; The agroman.net domain name expired on 2017-03-23, and the original
- ;; "http://www.agroman.net/corkscrew/corkscrew-2.0.tar.gz" now returns
- ;; bogus HTML. Perhaps it will yet return. Until then, use a mirror.
- (uri (string-append "https://downloads.openwrt.org/sources/"
- "corkscrew-" version ".tar.gz"))
- (sha256 (base32
- "1gmhas4va6gd70i2x2mpxpwpgww6413mji29mg282jms3jscn3qd"))))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/patpadgett/corkscrew")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "0g4pkczrc1zqpnxyyjwcjmyzdj5qqcpzwf1bm3965zdwp94bpppf"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'configure
;; Replace configure phase as the ./configure script does not like
- ;; CONFIG_SHELL and SHELL passed as parameters
+ ;; CONFIG_SHELL and SHELL passed as parameters.
(lambda* (#:key outputs build target #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bash (which "bash"))
;; Set --build and --host flags as the provided config.guess
- ;; is not able to detect them
+ ;; is not able to detect them.
(flags `(,(string-append "--prefix=" out)
,(string-append "--build=" build)
,(string-append "--host=" (or target build)))))
@@ -430,9 +429,9 @@ libssh library.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(doc (string-append out "/share/doc/" ,name "-" ,version)))
- (install-file "README" doc)
+ (install-file "README.markdown" doc)
#t))))))
- (home-page "http://www.agroman.net/corkscrew")
+ (home-page "https://github.com/patpadgett/corkscrew")
(synopsis "SSH tunneling through HTTP(S) proxies")
(description
"Corkscrew tunnels SSH connections through most HTTP and HTTPS proxies.