summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-10-13 00:32:14 +0200
committerLudovic Courtès <ludo@gnu.org>2014-10-13 00:32:14 +0200
commit817efe8bb14f298600c81713985160f76553431f (patch)
treebcf1d5f7765a2319ed16765e2f0efe4c2186b32e /gnu/packages/ssh.scm
parente3703818db1372d6469e74e101ed79a863854b45 (diff)
gnu: guile-ssh: Update to 0.7.1.
* gnu/packages/ssh.scm (guile-ssh)[source]: Update to 0.7.1. [arguments]: Remove ssh/Makefile.am fiddling from 'autoreconf' phase. Remove #:parallel-build? argument. [inputs]: Add LIBGCRYPT-1.5.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm25
1 files changed, 10 insertions, 15 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 00f8f6445d..2f1bb79c75 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -36,6 +36,7 @@
#:use-module (gnu packages)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake))
@@ -185,25 +186,21 @@ Additionally, various channel-specific options can be negotiated.")
(define-public guile-ssh
(package
(name "guile-ssh")
- (version "0.6.0")
+ (version "0.7.1")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/artyom-poptsov/libguile-ssh/archive/v"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artyom-poptsov/libguile-ssh.git")
+ (commit "e216e1d78bf93a9753ea813f930cac5e68e52180")))
(sha256
(base32
- "1v4y5vrwg0g6804pzbr160zahlqvj7k7iwys2bdpfzp7m2i47siq"))))
+ "1sbxhmynmpwfjwb3dp6lrc3cxi5kffqmb6klhx7wnkgqxvs61lsw"))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-cons-before
'configure 'autoreconf
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* "ssh/Makefile.am"
- (("-lssh_threads" match)
- (string-append "-L" (assoc-ref inputs "libssh")
- "/lib " match)))
-
+ (chmod "doc/version.texi" #o777) ;make it writable
(zero? (system* "autoreconf" "-vfi")))
(alist-cons-after
'install 'fix-libguile-ssh-file-name
@@ -225,9 +222,6 @@ Additionally, various channel-specific options can be negotiated.")
(assoc-ref %outputs "out")
"/share/guile/site/2.0"))
- ;; Building the .go requires building libguile-ssh.so first.
- #:parallel-build? #f
-
;; Tests are not parallel-safe.
#:parallel-tests? #f))
(native-inputs `(("autoconf" ,autoconf)
@@ -237,7 +231,8 @@ Additionally, various channel-specific options can be negotiated.")
("pkg-config" ,pkg-config)
("which" ,which)))
(inputs `(("guile" ,guile-2.0)
- ("libssh" ,libssh-0.5)))
+ ("libssh" ,libssh)
+ ("libgcrypt" ,libgcrypt-1.5)))
(synopsis "Guile bindings to libssh")
(description
"Guile-SSH is a library that provides access to the SSH protocol for