summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-11-13 01:00:02 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-11-13 01:00:00 +0100
commitf2bfc31f178c27b1ee37a8356b075cf64c086343 (patch)
tree909318366fae9918d2a6f78ec0182fdf78626073 /gnu/packages/ssh.scm
parentd0118c9930f1f4fac7c9f75c3894b141566561ec (diff)
gnu: dropbear: Update to 2022.83.
* gnu/packages/ssh.scm (dropbear): Update to 2022.83. [arguments]: Remove obsolete part of 'enable-x11-forwarding phase.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 6a3779ee55..22ce01210c 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -508,7 +508,7 @@ responsive, especially over Wi-Fi, cellular, and long-distance links.")
(define-public dropbear
(package
(name "dropbear")
- (version "2022.82")
+ (version "2022.83")
(source
(origin
(method url-fetch)
@@ -516,7 +516,7 @@ responsive, especially over Wi-Fi, cellular, and long-distance links.")
"https://matt.ucc.asn.au/dropbear/releases/"
"dropbear-" version ".tar.bz2"))
(sha256
- (base32 "1lbmmmm8f56p24c6jq74rg2kw6kl3w4i5h10vnxjigq2phmqs0rs"))
+ (base32 "0fs495ks354qcfj4k5bwg6m50vbl8az03gjymmqm2jy9zcgi4nmw"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -534,12 +534,6 @@ responsive, especially over Wi-Fi, cellular, and long-distance links.")
#:phases #~(modify-phases %standard-phases
(add-after 'unpack 'enable-x11-forwarding
(lambda _
- ;; The following patch was retrieved from:
- ;; https://github.com/mkj/dropbear/commit/
- ;; 0292aacdf0aa57d03f2a3ab7e53cf650e6f29389.
- (substitute* "svr-x11fwd.c"
- (("DROPBEAR_CHANNEL_PRIO_INTERACTIVE")
- "DROPBEAR_PRIO_LOWDELAY"))
(substitute* "default_options.h"
(("#define DROPBEAR_X11FWD 0")
"#define DROPBEAR_X11FWD 1")))))))