summaryrefslogtreecommitdiff
path: root/gnu/packages/sssd.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-20 23:38:50 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-21 00:44:07 -0400
commit8f0a110503a1936d60f24feec2ebdcb89e502b91 (patch)
tree07a1c6af951b347d26b62c2b82826644536665db /gnu/packages/sssd.scm
parent704f47733372cf902e2124ea0fec4b281a018eac (diff)
gnu: adcli: Delete use-local-docbook phase.
* gnu/packages/sssd.scm (adcli) [arguments]: Delete use-local-docbook phase. [native-inputs]: Replace docbook-xml with docbook-xml-4.3. Add libxml2.
Diffstat (limited to 'gnu/packages/sssd.scm')
-rw-r--r--gnu/packages/sssd.scm30
1 files changed, 6 insertions, 24 deletions
diff --git a/gnu/packages/sssd.scm b/gnu/packages/sssd.scm
index 051d7df014..17ae9b4ab1 100644
--- a/gnu/packages/sssd.scm
+++ b/gnu/packages/sssd.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2021, 2022 Remco van 't Veer <remco@remworks.net>
+;;; Copyright © 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -81,37 +82,18 @@
`(#:configure-flags
;; The net tool is used to update the stored machine key for samba.
(list (string-append "--with-samba-data-tool="
- (assoc-ref %build-inputs "samba") "/bin/net"))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'use-local-docbook
- ;; Patch Makefile and docs to use local docbook resources.
- (lambda _
- (let* ((docbook-xml (assoc-ref %build-inputs "docbook-xml"))
- (docbook-xsl (assoc-ref %build-inputs "docbook-xsl"))
- (xsldir (string-append docbook-xsl "/xml/xsl/docbook-xsl-"
- ,(package-version docbook-xsl))))
- (with-directory-excursion "doc"
- (substitute*
- '("Makefile.am" "adcli.xml" "adcli-devel.xml" "adcli-docs.xml")
- (("http://docbook.sourceforge.net/release/xsl/current(/[^\"]*)" _ path)
- (string-append xsldir path))
- (("http://www.oasis-open.org/docbook/xml/4.3/docbookx.dtd")
- (string-append docbook-xml "/xml/dtd/docbook/docbookx.dtd")))
- (substitute* "Makefile.am"
- (("\\$\\(XMLTO\\)" xmlto)
- (string-append xmlto " --searchpath " xsldir "/html"))))))))))
+ (search-input-file %build-inputs "bin/net")))))
(native-inputs
(list autoconf
automake
- docbook-xml
+ docbook-xml-4.3
docbook-xsl
libtool
+ libxml2 ;for XML_CATALOG_FILES
libxslt
- util-linux ; For `rev` command used in tests.
+ util-linux ;For `rev` command used in tests.
xmlto))
- (inputs
- (list cyrus-sasl mit-krb5 samba openldap))
+ (inputs (list cyrus-sasl mit-krb5 samba openldap))
(home-page "https://gitlab.freedesktop.org/realmd/adcli/")
(synopsis "Helper library and tools for Active Directory client operations")
(description "@command{adcli} is a command‐line tool to join a computer to