summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-07 11:54:03 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-07 11:54:03 +0200
commitaeafff536f933b07836b14d089dfc52b0e432ec9 (patch)
tree4ede554999f98cf9e19c04098c934db52efae795 /gnu/packages/statistics.scm
parent9dee9e8ffe4650949bd3ad2edf559cf4a33e9e6e (diff)
parentf82c58539e1f7b9b864e68ea2ab0c6a17c15fbb5 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm63
1 files changed, 63 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 43f9042e9c..1288d9d7ef 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -792,6 +792,29 @@ generation in R using Literate Programming techniques.")
;; here.
(license license:gpl2+)))
+(define-public r-knitrbootstrap
+ (package
+ (name "r-knitrbootstrap")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "knitrBootstrap" version))
+ (sha256
+ (base32
+ "0pshn2slzqwpryklslsxwh1dmqcnwv6bwi7yfm6m342wjybpk0wl"))))
+ (properties `((upstream-name . "knitrBootstrap")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-knitr" ,r-knitr)
+ ("r-rmarkdown" ,r-rmarkdown)))
+ (home-page "https://github.com/jimhester/knitrBootstrap")
+ (synopsis "Knitr bootstrap framework")
+ (description
+ "This package provides a framework to create Bootstrap 3 HTML reports
+from knitr Rmarkdown.")
+ (license license:expat)))
+
(define-public r-microbenchmark
(package
(name "r-microbenchmark")
@@ -2617,6 +2640,46 @@ noncentral hypergeometric distribution (also called extended hypergeometric
distribution).")
(license license:gpl3+)))
+(define-public r-runit
+ (package
+ (name "r-runit")
+ (version "0.4.31")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RUnit" version))
+ (sha256
+ (base32
+ "1jqr871jkll2xmk7wk5hv1z3a36hyn2ibgivw7bwk4b346940xlx"))))
+ (properties `((upstream-name . "RUnit")))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/RUnit")
+ (synopsis "R unit test framework")
+ (description
+ "This package provides R functions implementing a standard unit testing
+framework, with additional code inspection and report generation tools.")
+ (license license:gpl2+)))
+
+(define-public r-zoo
+ (package
+ (name "r-zoo")
+ (version "1.7-13")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "zoo" version))
+ (sha256
+ (base32
+ "0m67bnrg7r1jxvs9p7rpa430szp5qfp65r056yb8bivpc16jd98c"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lattice" ,r-lattice)))
+ (home-page "http://zoo.R-Forge.R-project.org/")
+ (synopsis "S3 infrastructure for regular and irregular time series")
+ (description "This package contains an S3 class with methods for totally
+ordered indexed observations. It is particularly aimed at irregular time
+series of numeric vectors/matrices and factors.")
+ (license license:gpl2+)))
+
(define-public r-ztable
(package
(name "r-ztable")