summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 09:08:30 +0100
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 10:52:52 +0100
commitc4e826bbd2dd22bd7005cbb5e32e2a5018e6216d (patch)
tree4c5d43ad7183ef8ddb4205e03405dc05ad1a4916 /gnu/packages/statistics.scm
parentd059485257bbe5b4f4d903b357ec99a3af2d4f39 (diff)
gnu: Add r-esc.
* gnu/packages/statistics.scm (r-esc): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 9761b9ceaf..86a818da9e 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -6058,3 +6058,28 @@ Helper functions to apply the Correcting for Outcome Reporting Bias (CORB)
method to correct for outcome reporting bias in a meta-analysis (van Aert &
Wicherts, 2020).")
(license license:gpl2+)))
+
+(define-public r-esc
+ (package
+ (name "r-esc")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "esc" version))
+ (sha256
+ (base32
+ "0gns7gz55p6pha05413r3hlvd7f2v1amxkg13d197mab1ypqic7q"))))
+ (properties `((upstream-name . "esc")))
+ (build-system r-build-system)
+ (home-page "https://strengejacke.github.io/esc/")
+ (synopsis
+ "Effect Size Computation for Meta Analysis")
+ (description
+ "Implementation of the web-based
+@url{http://www.campbellcollaboration.org/escalc/html/EffectSizeCalculator-Home.php,'Practical
+Meta-Analysis Effect Size Calculator'} from David B. Wilson in R. Based on the
+input, the effect size can be returned as standardized mean difference, Cohen's
+f, Hedges' g, Pearson's r or Fisher's transformation z, odds ratio or log odds,
+or eta squared effect size.")
+ (license license:gpl3)))