summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-26 23:19:03 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 00:34:28 +0100
commit91e0f01f0eb8dee933b954da9ea1c3fcf8555531 (patch)
treed7329e2f6bc64ad266f8e9e643a0fdda622636b7 /gnu/packages/syncthing.scm
parent1bf7ed71b2de67f9c5b095fae081cb607ddd7187 (diff)
gnu: go-github-com-audriusbutkevicius-recli: Move to golang-xyz.
* gnu/packages/syncthing.scm (go-github-com-audriusbutkevicius-recli): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I1494e60367873ba5ddbfe0725cd8a0ed02d8cb9e
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 4314cca93a..cd88abe368 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -213,32 +213,6 @@ notification area icon for Syncthing. Supported Syncthing features:
(define-public qsyncthingtray
(deprecated-package "qsyncthingtray" syncthing-gtk))
-(define-public go-github-com-audriusbutkevicius-recli
- (package
- (name "go-github-com-audriusbutkevicius-recli")
- (version "0.0.5")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/AudriusButkevicius/recli")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1m1xna1kb78pkmr1lfmvvnpk9j7c4x71j3a7c6vj7zpzc4srpsmf"))))
- (build-system go-build-system)
- (inputs
- (list go-github-com-pkg-errors go-github-com-urfave-cli))
- (arguments
- `(#:import-path "github.com/AudriusButkevicius/recli"))
- (synopsis "Reflection-based CLI generator")
- (description "For a given struct, @code{recli} builds a set of
-@code{urfave/cli} commands which allows you to modify it from the command line.
-It is useful for generating command line clients for your application
-configuration that is stored in a Go struct.")
- (home-page "https://github.com/AudriusButkevicius/recli")
- (license mpl2.0)))
-
(define-public go-github-com-calmh-du
(package
(name "go-github-com-calmh-du")