summaryrefslogtreecommitdiff
path: root/gnu/packages/telephony.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-05-03 06:44:06 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-05-08 15:50:22 +0200
commite5463baf2ce21cd2abc7ac5576401ae7ee7eb28c (patch)
tree12caf1b37f396beebfe554d0f9d629cc759c2937 /gnu/packages/telephony.scm
parent82058bf3e003231b127abf3e57bda63199a5e15b (diff)
gnu: twinkle: Update package definition.
* gnu/packages/patches/twinkle-bcg729.patch: New file. * gnu/packages/telephony.scm (twinkle)[source](patches): Use it. [build-system]: Change from cmake-build-system to qt-build-system. [arguments]<#:configure-flags>: Add "-DWITH_ZRTP", "-DWITH_G729". [arguments]<#:phases>[wrap-executable]: Delete phase. [native-inputs]: Move readline, file, ucommon, ccrtp, libxml2, speex, speexdsp, libsndfile, alsa-lib to ... [inputs]: ... here. Add bcg729, zrtpcpp, libilbc. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/telephony.scm')
-rw-r--r--gnu/packages/telephony.scm85
1 files changed, 42 insertions, 43 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index dea775d0a7..a866ecfa98 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -61,6 +61,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages libcanberra)
+ #:use-module (gnu packages linphone)
#:use-module (gnu packages linux)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
@@ -654,59 +655,57 @@ Mumble consists of two applications for separate usage:
(package
(name "twinkle")
(version "1.10.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/LubosD/twinkle")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0s0gi03xwvzp02ah4q6j33r9jx9nbayr6dxlg2ck9pwbay1nq1hx"))))
- (build-system cmake-build-system)
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/LubosD/twinkle")
+ (commit
+ (string-append "v" version))))
+ (file-name
+ (git-file-name name version))
+ (patches
+ (search-patches "twinkle-bcg729.patch")) ; To support new BCG729 API.
+ (sha256
+ (base32
+ "0s0gi03xwvzp02ah4q6j33r9jx9nbayr6dxlg2ck9pwbay1nq1hx"))))
+ (build-system qt-build-system)
(arguments
- `(#:tests? #f ; no test target
- #:configure-flags '("-DWITH_SPEEX=On")
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-program (string-append out "/bin/twinkle")
- `("QT_PLUGIN_PATH" ":" prefix
- ,(map (lambda (label)
- (string-append (assoc-ref inputs label)
- "/lib/qt5/plugins"))
- '("qtbase" "qtdeclarative")))
- `("QML2_IMPORT_PATH" ":" prefix
- ,(map (lambda (label)
- (string-append (assoc-ref inputs label)
- "/lib/qt5/qml"))
- '("qtdeclarative" "qtquickcontrols"))))
- #t))))))
+ `(#:tests? #f ; no test target
+ #:configure-flags
+ (list
+ ;; FIX-ME: Make Twinkle compatible with libre version of iLBC.
+ ;; "-DWITH_ILBC=On" ; For iLBC Codec Support
+ "-DWITH_ZRTP=On" ; For ZRTP Support
+ "-DWITH_G729=On" ; For G729 Codec Support
+ "-DWITH_SPEEX=On"))) ; For Speex Codec Support
(native-inputs
`(("bison" ,bison)
("flex" ,flex)
- ("readline" ,readline)
- ("file" ,file)
- ("ucommon" ,ucommon)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("bcg729" ,bcg729)
+ ("zrtpcpp" ,zrtpcpp)
("ccrtp" ,ccrtp)
+ ("file" ,file)
+ ("libilbc" ,libilbc)
+ ("libsndfile" ,libsndfile)
("libxml2" ,libxml2)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtquickcontrols" ,qtquickcontrols)
+ ("readline" ,readline)
("speex" ,speex)
("speexdsp" ,speexdsp)
- ("libsndfile" ,libsndfile)
- ("alsa-lib" ,alsa-lib)
- ("qttools" ,qttools)))
- (inputs
- `(("qtbase" ,qtbase)
- ("qtdeclarative" ,qtdeclarative)
- ("qtquickcontrols" ,qtquickcontrols)))
- (home-page "http://twinkle.dolezel.info/")
+ ("ucommon" ,ucommon)))
(synopsis "Softphone for voice over IP and instant messaging")
(description "Twinkle is a softphone for your voice over IP and instant
-messaging communcations using the SIP protocol. You can use it for direct IP
-phone to IP phone communication or in a network using a SIP proxy to route your
-calls and messages")
+messaging communcations using the SIP protocol. You can use it for direct
+IP phone to IP phone communication or in a network using a SIP proxy to route
+your calls and messages.")
+ (home-page "http://twinkle.dolezel.info/")
(license license:gpl2+)))
(define-public pjproject