summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-08 02:00:04 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-08 02:00:40 +0200
commitde15ca7af8cfb92f716ad8600f9295a2dca581a2 (patch)
tree3a6991f8a2aa57f75660f2e98c997ccff628685e /gnu/packages/terminals.scm
parentcd00881d72830ef9293c2693a9eb24d5692b2ab8 (diff)
gnu: beep: Update to 1.4.12.
* gnu/packages/terminals.scm (beep): Update to 1.4.12. [arguments]: Set $(CC) #:make-flag. Manually substitute the correct value of make check's $(PWD). (!)
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 58fd569ff2..59949daf21 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016, 2017, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
-;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
@@ -559,7 +559,7 @@ to all types of devices that provide serial consoles.")
(define-public beep
(package
(name "beep")
- (version "1.4.10")
+ (version "1.4.12")
(source
(origin
(method git-fetch)
@@ -572,11 +572,12 @@ to all types of devices that provide serial consoles.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "05c2gxfqc12rgp88c65q7f5ha9gzh222vdh0qpdq1zmyhqj43pq1"))))
+ (base32 "0dgrb5yg4ys1fa4hs95iz3m2yhryfzzw0j6g6yf6vhbys4ihcf40"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
- (list (string-append "prefix=" (assoc-ref %outputs "out"))
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "prefix=" (assoc-ref %outputs "out"))
(string-append "pkgdocdir=$(docdir)/" ,name "-" ,version))
#:phases
(modify-phases %standard-phases
@@ -585,9 +586,14 @@ to all types of devices that provide serial consoles.")
(lambda _
(substitute* "GNUmakefile"
(("/bin/bash")
- (which "bash")))
+ (which "bash"))
+ ;; XXX In the build environment, $(PWD) is the *parent* directory
+ ;; /tmp/guix-build-beep-x.y.drv-0! A pure guix shell works fine.
+ (("\\$\\(PWD\\)" pwd)
+ (string-append pwd "/source")))
(substitute* (find-files "tests" "\\.expected")
;; The build environment lacks /dev/{console,tty*}.
+ ;; In fact, even nckx's regular Guix System lacks ttyS1…
((": Permission denied")
": No such file or directory")))))))
(synopsis "Linux command-line utility to control the PC speaker")