summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2022-09-05 19:55:33 +0200
committerChristopher Baines <mail@cbaines.net>2022-09-10 11:26:40 +0100
commit37e4015f46583e7fb314868876ff70b424a6154c (patch)
tree3683ec63d82a12389b64705562583c8a699bfa41 /gnu/packages/tex.scm
parentad1d3f98b1d6f498d7f3e13d810f417ef3e7df5d (diff)
gnu: Add texlive-latex-seqsplit.
* gnu/packages/tex.scm (texlive-latex-seqsplit): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5e0228f2ab..530ba5070a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5103,6 +5103,27 @@ recent classes such as powerdot or beamer, both of which are tuned to
(define-deprecated-package texlive-latex-seminar texlive-seminar)
+(define-public texlive-latex-seqsplit
+ (package
+ (inherit (simple-texlive-package
+ "texlive-latex-seqsplit"
+ (list "doc/latex/seqsplit/"
+ "tex/latex/seqsplit/")
+ (base32 "1vwzs90520qsk22djl6gs6gpqx83y4b19kziirwj2xwbivcfk1h4")
+ #:trivial? #t))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/seqsplit")
+ (synopsis "Split long sequences of characters in a neutral way")
+ (description
+ "@code{seqsplit} provides a command @code{\\seqsplit}, which makes its
+argument splittable anywhere, and then leaves the TeX paragraph-maker to do the
+splitting. The package is suitable for situations when one needs to type long
+sequences of letters or of numbers in which there is no obvious break points to
+be found, such as in base-sequences in genes or calculations of transcendental
+numbers. While the package may obviously be used to typeset DNA sequences, the
+user may consider the @code{dnaseq} as a rather more powerful alternative.")
+ (license license:lppl1.3+)))
+
(define-public texlive-latex-stackengine
(package
(inherit (simple-texlive-package