summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 15:10:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:34 +0200
commit428c0277aa9462193598fb11bb042f64d7e4f77f (patch)
tree881ec179e8bdbc0560813dc2c9e788c31048cbaf /gnu/packages/tex.scm
parent59befed247b169905bc5f51430e082df39fa101c (diff)
gnu: Add texlive-penlight.
* gnu/packages/tex.scm (texlive-penlight): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 21ba24c319..ee08697703 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11792,6 +11792,25 @@ multimedia (audio, video, 3D), hyperlinks and other actions, triggering
events, transitions, and attachments.")
(license license:bsd-0)))
+(define-public texlive-penlight
+ (package
+ (name "texlive-penlight")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/luatex/penlight/"
+ "tex/luatex/penlight/")
+ (base32
+ "1jdq8x0rbknlvrlh2wc7q5gd463xhi845ajkkiirz65n23m7wyg6")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/penlight")
+ (synopsis "Penlight Lua libraries made available to LuaLaTeX users")
+ (description
+ "This LuaLaTeX package provides a wrapper to use the penlight Lua
+libraries with LuaLaTeX, with some extra functionality added.")
+ (license license:expat)))
+
(define-public texlive-pgf
(package
(name "texlive-pgf")