summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:28 +0200
commit66f6ff2aa75804efe603e251a50ed645ffea3f88 (patch)
treecae296f49f34bd24a7033055aae7ad3fdb009ba7 /gnu/packages/tex.scm
parente44f9c258897079e4786491732d37dd5bc5964e5 (diff)
gnu: Add texlive-williams.
* gnu/packages/tex.scm (texlive-williams): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 69d2062851..bca00f2f70 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -99770,6 +99770,25 @@ across columns or pages and display formulas separated from their introductory
paragraph.")
(license license:lppl1.3c)))
+(define-public texlive-williams
+ (package
+ (name "texlive-williams")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/williams/" "tex/latex/williams/")
+ (base32
+ "1rk7x20a23mq3r920hr96m65x48040q8m0ps6in91qlf77fz0lpw")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/williams")
+ (synopsis "Miscellaneous macros by Peter Williams")
+ (description
+ "The bundle provides two packages: @code{antree}, which provides macros for
+annotated node trees, and @code{toklist}, which is an implementation of
+Knuth's token list macros, to be found on pp.378--379 of the @emph{TeXbook}.")
+ (license license:lppl)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar