summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorFabio Natali <me@fabionatali.com>2022-07-16 10:15:42 +0100
committerLudovic Courtès <ludo@gnu.org>2022-08-03 17:43:26 +0200
commit6815bdb95c1ed8c6d522623d51bda7d8059e4967 (patch)
tree9d978ec145030f3e8642f4695257b93e06ad2f63 /gnu/packages/tex.scm
parente8ed95ddf884d1b958eed0da37d5b843c5e40dfe (diff)
gnu: Add texlive-mdframed.
* gnu/packages/tex.scm (texlive-mdframed): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ff38c97c5d..b2e49e3a2e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2021 Thiago Jung Bauermann <bauermann@kolabnow.com>
;;; Copyright © 2022 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2022 Fabio Natali <me@fabionatali.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -11082,3 +11083,23 @@ to Norsk of standard “LaTeX names”.")
Danish in @code{babel}. It provides all the necessary macros, definitions and
settings to typeset Danish documents.")
(license license:lppl1.3c+))))
+
+(define-public texlive-mdframed
+ (package
+ (inherit
+ (simple-texlive-package
+ "texlive-mdframed"
+ (list
+ "doc/latex/mdframed/"
+ "source/latex/mdframed/"
+ "tex/latex/mdframed/")
+ (base32 "1i5rm946wg43rjckxlfhx79zfx5cgd3bxk71206hd1dqkrgpdpa8")
+ #:trivial? #t))
+ (home-page "https://ctan.org/pkg/mdframed")
+ (synopsis "Framed environments that can split at page boundaries")
+ (description
+ "The @code{mdframed} package develops the facilities of @code{framed} in
+providing breakable framed and coloured boxes. The user may instruct the
+package to perform its operations using default LaTeX commands, PStricks or
+TikZ.")
+ (license license:lppl)))